import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span.*?data-snippet-php=\"(.*?)\".*?>.*?<\\/span>";
final String string = "HTML Code<br><span class=\"block\" title=\"Label: Titel\" data-snippet-php=\"<?php _e('Titel','grid_test') ?>\" editable=\"false\">[ Titel ]</span>: <span class=\"block\" title=\"Datenfeld: Titel\" data-snippet-bind=\"#: post_title #\" editable=\"false\">{ post_title }</span> text text text <span class=\"block\" title=\"Label: Desc\" data-snippet-php=\"<?php _e('Desc','grid_test') ?>\" editable=\"false\">[ Desc ]</span>: text text text";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}