package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<span.*?data-snippet-php="(.*?)".*?>.*?<\/span>`)
var str = `HTML Code<br><span class="block" title="Label: Titel" data-snippet-php="<?php _e('Titel','grid_test') ?>" editable="false">[ Titel ]</span>: <span class="block" title="Datenfeld: Titel" data-snippet-bind="#: post_title #" editable="false">{ post_title }</span> text text text <span class="block" title="Label: Desc" data-snippet-php="<?php _e('Desc','grid_test') ?>" editable="false">[ Desc ]</span>: text text text`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}