// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<span.*?data-snippet-php="(.*?)".*?>.*?<\/span>"#).unwrap();
let string = "HTML Code<br><span class=\"block\" title=\"Label: Titel\" data-snippet-php=\"<?php _e('Titel','grid_test') ?>\" editable=\"false\">[ Titel ]</span>: <span class=\"block\" title=\"Datenfeld: Titel\" data-snippet-bind=\"#: post_title #\" editable=\"false\">{ post_title }</span> text text text <span class=\"block\" title=\"Label: Desc\" data-snippet-php=\"<?php _e('Desc','grid_test') ?>\" editable=\"false\">[ Desc ]</span>: text text text";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}