# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<span.*?data-snippet-php=\"(.*?)\".*?>.*?<\/span>"
test_str = "HTML Code<br><span class=\"block\" title=\"Label: Titel\" data-snippet-php=\"<?php _e('Titel','grid_test') ?>\" editable=\"false\">[ Titel ]</span>: <span class=\"block\" title=\"Datenfeld: Titel\" data-snippet-bind=\"#: post_title #\" editable=\"false\">{ post_title }</span> text text text <span class=\"block\" title=\"Label: Desc\" data-snippet-php=\"<?php _e('Desc','grid_test') ?>\" editable=\"false\">[ Desc ]</span>: text text text"
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.