re = /<span.*?data-snippet-php="(.*?)".*?>.*?<\/span>/m
str = 'HTML Code<br><span class="block" title="Label: Titel" data-snippet-php="<?php _e(\'Titel\',\'grid_test\') ?>" editable="false">[ Titel ]</span>: <span class="block" title="Datenfeld: Titel" data-snippet-bind="#: post_title #" editable="false">{ post_title }</span> text text text <span class="block" title="Label: Desc" data-snippet-php="<?php _e(\'Desc\',\'grid_test\') ?>" editable="false">[ Desc ]</span>: text text text'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result