using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span.*?data-snippet-php=""(.*?)"".*?>.*?<\/span>";
string substitution = @"$1";
string input = @"HTML Code<br><span class=""block"" title=""Label: Titel"" data-snippet-php=""<?php _e('Titel','grid_test') ?>"" editable=""false"">[ Titel ]</span>: <span class=""block"" title=""Datenfeld: Titel"" data-snippet-bind=""#: post_title #"" editable=""false"">{ post_title }</span> text text text <span class=""block"" title=""Label: Desc"" data-snippet-php=""<?php _e('Desc','grid_test') ?>"" editable=""false"">[ Desc ]</span>: text text text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}