const regex = /<span.*?data-snippet-php="(.*?)".*?>.*?<\/span>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span.*?data-snippet-php="(.*?)".*?>.*?<\\\/span>', 'gm')
const str = `HTML Code<br><span class="block" title="Label: Titel" data-snippet-php="<?php _e('Titel','grid_test') ?>" editable="false">[ Titel ]</span>: <span class="block" title="Datenfeld: Titel" data-snippet-bind="#: post_title #" editable="false">{ post_title }</span> text text text <span class="block" title="Label: Desc" data-snippet-php="<?php _e('Desc','grid_test') ?>" editable="false">[ Desc ]</span>: text text text`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);