#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])"
Local $sString = "ThisJustShowsWhereUnderscoresWouldBeInserted" & @CRLF & _
"Call_lower_After_re_sub_ToConvertToSnakeCase" & @CRLF & _
"camel2_camel2_case" & @CRLF & _
"getHTTPResponseCode" & @CRLF & _
"HTTPResponseCodeXYZ" & @CRLF & _
"capitalG" & @CRLF & _
"ACRONYM" & @CRLF & _
"Regular" & @CRLF & _
"https://stackoverflow.com/questions/1175208"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)