import re
regex = re.compile(r"(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])", flags=re.MULTILINE)
test_str = ("ThisJustShowsWhereUnderscoresWouldBeInserted\n"
"Call_lower_After_re_sub_ToConvertToSnakeCase\n"
"camel2_camel2_case\n"
"getHTTPResponseCode\n"
"HTTPResponseCodeXYZ\n"
"capitalG\n"
"ACRONYM\n"
"Regular\n"
"https://stackoverflow.com/questions/1175208")
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)