import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])";
final String string = "ThisJustShowsWhereUnderscoresWouldBeInserted\n"
+ "Call_lower_After_re_sub_ToConvertToSnakeCase\n"
+ "camel2_camel2_case\n"
+ "getHTTPResponseCode\n"
+ "HTTPResponseCodeXYZ\n"
+ "capitalG\n"
+ "ACRONYM\n"
+ "Regular\n"
+ "https://stackoverflow.com/questions/1175208";
final String subst = "_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}