re = /(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])/m
str = 'ThisJustShowsWhereUnderscoresWouldBeInserted
Call_lower_After_re_sub_ToConvertToSnakeCase
camel2_camel2_case
getHTTPResponseCode
HTTPResponseCodeXYZ
capitalG
ACRONYM
Regular
https://stackoverflow.com/questions/1175208'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result