import Foundation
let pattern = #"(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ThisJustShowsWhereUnderscoresWouldBeInserted
Call_lower_After_re_sub_ToConvertToSnakeCase
camel2_camel2_case
getHTTPResponseCode
HTTPResponseCodeXYZ
capitalG
ACRONYM
Regular
https://stackoverflow.com/questions/1175208
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)