using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])";
string substitution = @"_";
string input = @"ThisJustShowsWhereUnderscoresWouldBeInserted
Call_lower_After_re_sub_ToConvertToSnakeCase
camel2_camel2_case
getHTTPResponseCode
HTTPResponseCodeXYZ
capitalG
ACRONYM
Regular
https://stackoverflow.com/questions/1175208";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}