use strict;
my $str = 'ThisJustShowsWhereUnderscoresWouldBeInserted
Call_lower_After_re_sub_ToConvertToSnakeCase
camel2_camel2_case
getHTTPResponseCode
HTTPResponseCodeXYZ
capitalG
ACRONYM
Regular
https://stackoverflow.com/questions/1175208';
my $regex = qr/(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";