using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[.?!]|^)(?:СЛОВО2()|СЛОВО()(?:\1())?|[^.?!])++\2(?!\3)";
string substitution = @" ЗАМЕНА";
string input = @"Раз СЛОВО2 два СЛОВО.
Раз СЛОВО два СЛОВО2 три СЛОВО.
Раз СЛОВО два СЛОВО2.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}