import Foundation
let pattern = #"(?<=[.?!]|^)(?:СЛОВО2()|СЛОВО()(?:\1())?|[^.?!])++\2(?!\3)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Раз СЛОВО2 два СЛОВО.
Раз СЛОВО два СЛОВО2 три СЛОВО.
Раз СЛОВО два СЛОВО2.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" ЗАМЕНА"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)