re = /(?<=[.?!]|^)(?:СЛОВО2()|СЛОВО()(?:\1())?|[^.?!])++\2(?!\3)/
str = 'Раз СЛОВО2 два СЛОВО.
Раз СЛОВО два СЛОВО2 три СЛОВО.
Раз СЛОВО два СЛОВО2.'
subst = ' ЗАМЕНА'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result