const regex = /(?<=[.?!]|^)(?:СЛОВО2()|СЛОВО()(?:\1())?|[^.?!])++\2(?!\3)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[.?!]|^)(?:СЛОВО2()|СЛОВО()(?:\\1())?|[^.?!])++\\2(?!\\3)', 'g')
const str = `Раз СЛОВО2 два СЛОВО.
Раз СЛОВО два СЛОВО2 три СЛОВО.
Раз СЛОВО два СЛОВО2.`;
const subst = ` ЗАМЕНА`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);