use strict;
my $str = 'Раз СЛОВО2 два СЛОВО.
Раз СЛОВО два СЛОВО2 три СЛОВО.
Раз СЛОВО два СЛОВО2.';
my $regex = qr/(?<=[.?!]|^)(?:СЛОВО2()|СЛОВО()(?:\1())?|[^.?!])++\2(?!\3)/p;
my $subst = ' ЗАМЕНА';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";