import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[.?!]|^)(?:СЛОВО2()|СЛОВО()(?:\\1())?|[^.?!])++\\2(?!\\3)";
final String string = "Раз СЛОВО2 два СЛОВО.\n"
+ "Раз СЛОВО два СЛОВО2 три СЛОВО.\n"
+ "Раз СЛОВО два СЛОВО2.";
final String subst = " ЗАМЕНА";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}