#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\s+)?(.+?)(\s+)?(years?|months?).*"
Local $sString = " Eight years blah blah 50 blah blah, two years blah blah blah." & @CRLF & _
"Eight years blah blah 50 blah blah, two years blah blah blah." & @CRLF & _
"Eight months blah blah 50 blah blah, two years blah blah blah." & @CRLF & _
"One month blah blah 50 blah blah, two years blah blah blah."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")