import Foundation
let pattern = #"(\s+)?(.+?)(\s+)?(years?|months?).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Eight years blah blah 50 blah blah, two years blah blah blah.
Eight years blah blah 50 blah blah, two years blah blah blah.
Eight months blah blah 50 blah blah, two years blah blah blah.
One month blah blah 50 blah blah, two years blah blah blah.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)