re = /(\s+)?(.+?)(\s+)?(years?|months?).*/m
str = ' Eight years blah blah 50 blah blah, two years blah blah blah.
Eight years blah blah 50 blah blah, two years blah blah blah.
Eight months blah blah 50 blah blah, two years blah blah blah.
One month blah blah 50 blah blah, two years blah blah blah.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end