using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s+)?(.+?)(\s+)?(years?|months?).*";
string input = @" Eight years blah blah 50 blah blah, two years blah blah blah.
Eight years blah blah 50 blah blah, two years blah blah blah.
Eight months blah blah 50 blah blah, two years blah blah blah.
One month blah blah 50 blah blah, two years blah blah blah.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}