const regex = /(\s+)?(.+?)(\s+)?(years?|months?).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s+)?(.+?)(\\s+)?(years?|months?).*', 'gm')
const str = ` Eight years blah blah 50 blah blah, two years blah blah blah.
Eight years blah blah 50 blah blah, two years blah blah blah.
Eight months blah blah 50 blah blah, two years blah blah blah.
One month blah blah 50 blah blah, two years blah blah blah.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}