package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s+)?(.+?)(\s+)?(years?|months?).*`)
var str = ` Eight years blah blah 50 blah blah, two years blah blah blah.
Eight years blah blah 50 blah blah, two years blah blah blah.
Eight months blah blah 50 blah blah, two years blah blah blah.
One month blah blah 50 blah blah, two years blah blah blah.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}