import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s+)?(.+?)(\\s+)?(years?|months?).*";
final String string = " Eight years blah blah 50 blah blah, two years blah blah blah.\n"
+ "Eight years blah blah 50 blah blah, two years blah blah blah.\n"
+ "Eight months blah blah 50 blah blah, two years blah blah blah.\n"
+ "One month blah blah 50 blah blah, two years blah blah blah.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}