# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\pL\pN]*([\pL\pN](?:[\pL\pN_-]|(?![?.!])\pP(?=[\pL\pN\pP]))*)(?<!\pP)/$1\n/gu;t' <<< "Hello, _h_-ow a,r,..e you tod.'?.,,s ay's ?a.,.,
\"tim's work 'cool'asdas 'right' thr,ee-year-o_ld- 123123.\";
tim's work 'cool' asdas 'right' three-year-old 123123.
,,, asgd"