re = /[^\pL\pN]*([\pL\pN](?:[\pL\pN_-]|(?![?.!])\pP(?=[\pL\pN\pP]))*)(?<!\pP)/
str = 'Hello, _h_-ow a,r,..e you tod.\'?.,,s ay\'s ?a.,.,
"tim\'s work \'cool\'asdas \'right\' thr,ee-year-o_ld- 123123.";
tim\'s work \'cool\' asdas \'right\' three-year-old 123123.
,,, asgd'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result