import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"[^\pL\pN]*([\pL\pN](?:[\pL\pN_-]|(?![?.!])\pP(?=[\pL\pN\pP]))*)(?<!\pP)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello, _h_-ow a,r,..e you tod.'?.,,s ay's ?a.,.,
"tim's work 'cool'asdas 'right' thr,ee-year-o_ld- 123123.";
tim's work 'cool' asdas 'right' three-year-old 123123.
,,, asgd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)