use strict;
my $str = 'Hello, _h_-ow a,r,..e you tod.\'?.,,s ay\'s ?a.,.,
"tim\'s work \'cool\'asdas \'right\' thr,ee-year-o_ld- 123123.";
tim\'s work \'cool\' asdas \'right\' three-year-old 123123.
,,, asgd';
my $regex = qr/[^\pL\pN]*([\pL\pN](?:[\pL\pN_-]|(?![?.!])\pP(?=[\pL\pN\pP]))*)(?<!\pP)/up;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";