const regex = /[^\pL\pN]*([\pL\pN](?:[\pL\pN_-]|(?![?.!])\pP(?=[\pL\pN\pP]))*)(?<!\pP)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\pL\\pN]*([\\pL\\pN](?:[\\pL\\pN_-]|(?![?.!])\\pP(?=[\\pL\\pN\\pP]))*)(?<!\\pP)', 'gu')
const str = `Hello, _h_-ow a,r,..e you tod.'?.,,s ay's ?a.,.,
"tim's work 'cool'asdas 'right' thr,ee-year-o_ld- 123123.";
tim's work 'cool' asdas 'right' three-year-old 123123.
,,, asgd`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);