using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\pL\pN]*([\pL\pN](?:[\pL\pN_-]|(?![?.!])\pP(?=[\pL\pN\pP]))*)(?<!\pP)";
string substitution = @"$1\n";
string input = @"Hello, _h_-ow a,r,..e you tod.'?.,,s ay's ?a.,.,
""tim's work 'cool'asdas 'right' thr,ee-year-o_ld- 123123."";
tim's work 'cool' asdas 'right' three-year-old 123123.
,,, asgd";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}