# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\pL\pN]*([\pL\pN](?:[\pL\pN_-]|(?![?.!])\pP(?=[\pL\pN\pP]))*)(?<!\pP)"
test_str = ("Hello, _h_-ow a,r,..e you tod.'?.,,s ay's ?a.,.,\n"
"\"tim's work 'cool'asdas 'right' thr,ee-year-o_ld- 123123.\";\n\n\n"
"tim's work 'cool' asdas 'right' three-year-old 123123.\n\n"
" ,,, asgd")
subst = "$1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.