#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)[^\pL\pN]*([\pL\pN](?:[\pL\pN_-]|(?![?.!])\pP(?=[\pL\pN\pP]))*)(?<!\pP)"
Local $sString = "Hello, _h_-ow a,r,..e you tod.'?.,,s ay's ?a.,.," & @CRLF & _
""tim's work 'cool'asdas 'right' thr,ee-year-o_ld- 123123.";" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"tim's work 'cool' asdas 'right' three-year-old 123123." & @CRLF & _
"" & @CRLF & _
" ,,, asgd"
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)