# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\.(?![^.]+$)|[^\w\d\n.])+/-/gm;t' <<< "manuel fernandex – Index Prot.bla.otype 5 (pepito grillo).jpg
manuel-fernandex-Index-Prot-bla-otype-5-pepito-grillo-.jpg"