const regex = /(?:\.(?![^.]+$)|[^\w\d\n.])+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\.(?![^.]+$)|[^\\w\\d\\n.])+', 'gm')
const str = `manuel fernandex – Index Prot.bla.otype 5 (pepito grillo).jpg
manuel-fernandex-Index-Prot-bla-otype-5-pepito-grillo-.jpg`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);