using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\.(?![^.]+$)|[^\w\d\n.])+";
string substitution = @"-";
string input = @"manuel fernandex – Index Prot.bla.otype 5 (pepito grillo).jpg
manuel-fernandex-Index-Prot-bla-otype-5-pepito-grillo-.jpg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}