Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?:\.(?![^.]+$)|[^\w\d\n.])+
/
gm
Input 1
1
New
manuel fernandex – Index Prot.bla.otype 5 (pepito grillo).jpg manuel-fernandex-Index-Prot-bla-otype-5-pepito-grillo-.jpg
Substitution
-