re = /(^|\b)([5,9]\d{2,}|\d{4,})(\.\d+)? (dollar|\$)(\b|\n)/m
str = '501.34 dollar
500 dollar
I have 4500 dollar
1250.99 $
50000.252221121 dollar
200 dollar
350.99
I found new animal called 4500 dollariansaurus'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end