// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|\b)([5,9]\d{2,}|\d{4,})(\.\d+)? (dollar|\$)(\b|\n)").unwrap();
let string = "501.34 dollar
500 dollar
I have 4500 dollar
1250.99 $
50000.252221121 dollar
200 dollar
350.99
I found new animal called 4500 dollariansaurus";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}