#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?![^\S\r\n]*//)[^\S\r\n]*MessageBox\(\s*(?:[^,]*,){3}\s*(?!.*MB_TASKMODAL)"
Local $sString = "// Messagebox(a,b,c, mb_ok);" & @CRLF & _
"Messagebox(a,b,c, mb_ok|mb_taskmodal);" & @CRLF & _
"Messagebox(a,b,c, mb_ok);" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"MessageBox(NULL, txtStr, "Error", MB_OK); hellow" & @CRLF & _
"//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK);hellow" & @CRLF & _
"// MessageBox(NULL, txtStr, "Error ", | MB_OK);hellow" & @CRLF & _
"MessageBox( NULL, txtStr, "Error", MB_OK ); hellow " & @CRLF & _
"MessageBox( NULL, txtStr, "Error", MB_OK |MB_TASKMODAL); hellow" & @CRLF & _
"hellow" & @CRLF & _
"//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK); hellow" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" MessageBox(NULL, txtStr, "Error", MB_OK); hellow"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")