$re = '~^(?![^\S\r\n]*//)[^\S\r\n]*MessageBox\(\s*(?:[^,]*,){3}\s*(?!.*MB_TASKMODAL)~mi';
$str = '// Messagebox(a,b,c, mb_ok);
Messagebox(a,b,c, mb_ok|mb_taskmodal);
Messagebox(a,b,c, mb_ok);
MessageBox(NULL, txtStr, "Error", MB_OK); hellow
//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK);hellow
// MessageBox(NULL, txtStr, "Error ", | MB_OK);hellow
MessageBox( NULL, txtStr, "Error", MB_OK ); hellow
MessageBox( NULL, txtStr, "Error", MB_OK |MB_TASKMODAL); hellow
hellow
//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK); hellow
MessageBox(NULL, txtStr, "Error", MB_OK); hellow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);