import Foundation
let pattern = #"^(?![^\S\r\n]*//)[^\S\r\n]*MessageBox\(\s*(?:[^,]*,){3}\s*(?!.*MB_TASKMODAL)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
// Messagebox(a,b,c, mb_ok);
Messagebox(a,b,c, mb_ok|mb_taskmodal);
Messagebox(a,b,c, mb_ok);
MessageBox(NULL, txtStr, "Error", MB_OK); hellow
//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK);hellow
// MessageBox(NULL, txtStr, "Error ", | MB_OK);hellow
MessageBox( NULL, txtStr, "Error", MB_OK ); hellow
MessageBox( NULL, txtStr, "Error", MB_OK |MB_TASKMODAL); hellow
hellow
//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK); hellow
MessageBox(NULL, txtStr, "Error", MB_OK); hellow
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)