# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?![^\S\r\n]*//)[^\S\r\n]*MessageBox\(\s*(?:[^,]*,){3}\s*(?!.*MB_TASKMODAL)"
test_str = ("// Messagebox(a,b,c, mb_ok);\n"
"Messagebox(a,b,c, mb_ok|mb_taskmodal);\n"
"Messagebox(a,b,c, mb_ok);\n\n\n"
"MessageBox(NULL, txtStr, \"Error\", MB_OK); hellow\n"
"//MessageBox(NULL, \"SUCCESS\", \"SUCCESS \", MB_OK);hellow\n"
"// MessageBox(NULL, txtStr, \"Error \", | MB_OK);hellow\n"
"MessageBox( NULL, txtStr, \"Error\", MB_OK ); hellow \n"
"MessageBox( NULL, txtStr, \"Error\", MB_OK |MB_TASKMODAL); hellow\n"
"hellow\n"
"//MessageBox(NULL, \"SUCCESS\", \"SUCCESS \", MB_OK); hellow\n\n\n\n"
" MessageBox(NULL, txtStr, \"Error\", MB_OK); hellow")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.