import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^\\S\\r\\n]*//)[^\\S\\r\\n]*MessageBox\\(\\s*(?:[^,]*,){3}\\s*(?!.*MB_TASKMODAL)";
final String string = "// Messagebox(a,b,c, mb_ok);\n"
+ "Messagebox(a,b,c, mb_ok|mb_taskmodal);\n"
+ "Messagebox(a,b,c, mb_ok);\n\n\n"
+ "MessageBox(NULL, txtStr, \"Error\", MB_OK); hellow\n"
+ "//MessageBox(NULL, \"SUCCESS\", \"SUCCESS \", MB_OK);hellow\n"
+ "// MessageBox(NULL, txtStr, \"Error \", | MB_OK);hellow\n"
+ "MessageBox( NULL, txtStr, \"Error\", MB_OK ); hellow \n"
+ "MessageBox( NULL, txtStr, \"Error\", MB_OK |MB_TASKMODAL); hellow\n"
+ "hellow\n"
+ "//MessageBox(NULL, \"SUCCESS\", \"SUCCESS \", MB_OK); hellow\n\n\n\n"
+ " MessageBox(NULL, txtStr, \"Error\", MB_OK); hellow";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}