using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![^\S\r\n]*//)[^\S\r\n]*MessageBox\(\s*(?:[^,]*,){3}\s*(?!.*MB_TASKMODAL)";
string input = @"// Messagebox(a,b,c, mb_ok);
Messagebox(a,b,c, mb_ok|mb_taskmodal);
Messagebox(a,b,c, mb_ok);
MessageBox(NULL, txtStr, ""Error"", MB_OK); hellow
//MessageBox(NULL, ""SUCCESS"", ""SUCCESS "", MB_OK);hellow
// MessageBox(NULL, txtStr, ""Error "", | MB_OK);hellow
MessageBox( NULL, txtStr, ""Error"", MB_OK ); hellow
MessageBox( NULL, txtStr, ""Error"", MB_OK |MB_TASKMODAL); hellow
hellow
//MessageBox(NULL, ""SUCCESS"", ""SUCCESS "", MB_OK); hellow
MessageBox(NULL, txtStr, ""Error"", MB_OK); hellow";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}