const regex = new RegExp('^(?![^\\S\\r\\n]*//)[^\\S\\r\\n]*MessageBox\\(\\s*(?:[^,]*,){3}\\s*(?!.*MB_TASKMODAL)', 'gmi')
const str = `// Messagebox(a,b,c, mb_ok);
Messagebox(a,b,c, mb_ok|mb_taskmodal);
Messagebox(a,b,c, mb_ok);
MessageBox(NULL, txtStr, "Error", MB_OK); hellow
//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK);hellow
// MessageBox(NULL, txtStr, "Error ", | MB_OK);hellow
MessageBox( NULL, txtStr, "Error", MB_OK ); hellow
MessageBox( NULL, txtStr, "Error", MB_OK |MB_TASKMODAL); hellow
hellow
//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK); hellow
MessageBox(NULL, txtStr, "Error", MB_OK); hellow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}