use strict;
my $str = '// Messagebox(a,b,c, mb_ok);
Messagebox(a,b,c, mb_ok|mb_taskmodal);
Messagebox(a,b,c, mb_ok);
MessageBox(NULL, txtStr, "Error", MB_OK); hellow
//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK);hellow
// MessageBox(NULL, txtStr, "Error ", | MB_OK);hellow
MessageBox( NULL, txtStr, "Error", MB_OK ); hellow
MessageBox( NULL, txtStr, "Error", MB_OK |MB_TASKMODAL); hellow
hellow
//MessageBox(NULL, "SUCCESS", "SUCCESS ", MB_OK); hellow
MessageBox(NULL, txtStr, "Error", MB_OK); hellow';
my $regex = qr~^(?![^\S\r\n]*//)[^\S\r\n]*MessageBox\(\s*(?:[^,]*,){3}\s*(?!.*MB_TASKMODAL)~mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}