# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^news\\/[0-9]+-(.*)/headlines\\/$1/g;t' <<< "news/122-windows-10-the-final-countdown"